Centos 7: qt5 packages missing when installing synergy-1.9.1

The fix is to installed qt5-qtbase & qt5-qtbase-gui:

yum install qt5-qtbase qt5-qtbase-gui

The specific warnings are:# rpm -i synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64.rpm
error: Failed dependencies:
libQt5Core.so.5()(64bit) is needed by synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64
libQt5Core.so.5(Qt_5)(64bit) is needed by synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64
libQt5Core.so.5(Qt_5.6)(64bit) is needed by synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64
libQt5Gui.so.5()(64bit) is needed by synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64
libQt5Gui.so.5(Qt_5)(64bit) is needed by synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64
libQt5Network.so.5()(64bit) is needed by synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64
libQt5Network.so.5(Qt_5)(64bit) is needed by synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64
libQt5Widgets.so.5()(64bit) is needed by synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64
libQt5Widgets.so.5(Qt_5)(64bit) is needed by synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64

Leave a Reply

Your email address will not be published. Required fields are marked *